nixos-config_test/hosts/modules/auto-upgrade.nix
2023-08-01 05:06:16 +00:00

15 lines
495 B
Nix

{ config, inputs, ... }:
let
inherit (config.networking) hostName; # Inherit variable
isClean = inputs.self ? rev; # Only enable if current config came from clean tree
in
{
system.autoUpgrade = { # NixOS auto upgrade
enable = isClean;
dates = "hourly";
flags = [
"--refresh"
];
};
}