nixos-config/flake.nix
2023-08-11 16:10:47 +02:00

27 lines
1.2 KiB
Nix

{
description = "NixOS configuration";
inputs = { # All flake references
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable"; # Default stable nix packages
home-manager = { # User package management
url = "github:nix-community/home-manager";
inputs.nixpkgs.follows = "nixpkgs";
};
hyprland.url = "github:hyprwm/Hyprland"; # packages hyprland
# stylix.url = "github:danth/stylix";
};
outputs = attrs @ { self, nixpkgs, home-manager, hyprland, ... }: {
nixosConfigurations = { # NixOS Configuration
merkur = nixpkgs.lib.nixosSystem { # Flake "merkur" (Notebook)
system = "x85_64-linux";
specialArgs = attrs; # Pass flake attrs to our config
modules = [ ./hosts/merkur.nix ];
};
};
};
}